Dashboard Loading Issues
Incident Report for NextRoll
Resolved
The issue has been resolved. We apologize for any inconvenience.
Posted Jan 15, 2020 - 11:16 PST
Investigating
We are currently investigating an issue where the home campaigns dashboard is failing to load for some users.
Posted Jan 15, 2020 - 10:42 PST
This incident affected: AdRoll (AdRoll Dashboard).