Campaign Edit Issues
Incident Report for NextRoll
Resolved
This issue has been resolved.
Posted Mar 23, 2020 - 14:47 PDT
Investigating
We are aware that some users are experiencing issues creating and editing Campaigns from the dashboard. We are currently investigating.
Posted Mar 23, 2020 - 14:20 PDT
This incident affected: Retargeting Buyflow.