Subscription management vendor outage impacting new AdRoll customer signs-ups and subscriptions
Incident Report for NextRoll
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 16:59 PDT
Identified
Paid subscription actions are unavailable on app.adroll.com.
Posted Aug 31, 2021 - 15:30 PDT
This incident affected: AdRoll (AdRoll Subscription Signup).