AdRoll BU reports that span more than a month are experiencing delays.
Incident Report for NextRoll
Resolved
This incident has been resolved.
Posted Aug 13, 2021 - 09:07 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2021 - 12:11 PDT
This incident affected: AdRoll (AdRoll Dashboard).